Positions and Balances not properly updating
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Jun 10, 2020 - 23:12 UTC
Investigating
We are currently investigating this issue.
Posted Jun 10, 2020 - 22:59 UTC
This incident affected: trade.dydx.exchange.