Balances / Positions Updating Slowly
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 20:57 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2020 - 18:24 UTC
This incident affected: trade.dydx.exchange.