Slowness in Updating the UI for Deposits/Withdrawals/Tradese
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Mar 06, 2020 - 02:13 UTC
Investigating
We are currently investigating this issue.
Posted Mar 06, 2020 - 02:09 UTC
This incident affected: trade.dydx.exchange.