We are seeing orders fail to process
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 04:53 UTC
Update
We are continuing to investigate this issue.
Posted Jul 23, 2020 - 04:53 UTC
Investigating
We are currently investigating this issue.
Posted Jul 23, 2020 - 04:41 UTC
This incident affected: trade.dydx.exchange.