Orderbook Loading Slowly
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 16:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2020 - 15:48 UTC
Investigating
We are currently investigating this issue.
Posted Mar 16, 2020 - 15:35 UTC
This incident affected: trade.dydx.exchange.