Price Chart & Market Statistics Loading Slowly
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 02:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2020 - 21:24 UTC
Investigating
We are currently investigating this issue.
Posted Feb 27, 2020 - 21:03 UTC
This incident affected: trade.dydx.exchange.