Slowness is retrieving orders.
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Nov 25, 2020 - 12:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 25, 2020 - 11:19 UTC
This incident affected: trade.dydx.exchange.