Investigating orders being unable to be placed
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Apr 29, 2020 - 19:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2020 - 19:11 UTC
Investigating
We are currently investigating this issue.
Posted Apr 29, 2020 - 18:59 UTC
This incident affected: trade.dydx.exchange.