Balances sometimes not updating in app
Incident Report for dYdX V3
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 20:23 UTC
Investigating
On-chain balances are sometimes not being reflected in the app. We are looking into why this is happening
Posted Mar 16, 2020 - 15:21 UTC
This incident affected: trade.dydx.exchange.