Balances / Positions Updating Slowly
Incident Report for dYdX V3
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 10:31 UTC
Investigating
Balances and positions are updating slowly in the app as there is a backlog of transactions to work through
Posted Mar 11, 2020 - 10:20 UTC
This incident affected: trade.dydx.exchange.