App not loading
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 06:03 UTC
Investigating
Some parts of the app are not loading
Posted Feb 13, 2020 - 05:43 UTC
This incident affected: trade.dydx.exchange.