UI Slowness in Updating Balances
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Mar 09, 2020 - 17:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 09, 2020 - 17:10 UTC
Investigating
We are currently investigating this issue.
Posted Mar 09, 2020 - 16:44 UTC
This incident affected: trade.dydx.exchange.