Slowness in Updating the balances on the UI
Incident Report for dYdX V3
Resolved
This incident has been resolved.
Posted Mar 13, 2020 - 03:03 UTC
Investigating
We are currently investigating this issue.
Posted Mar 13, 2020 - 01:49 UTC
This incident affected: trade.dydx.exchange.