Orderbook displaying incorrectly
Incident Report for dYdX V3
Resolved
This incident has been resolved.
Posted Jul 06, 2020 - 21:21 UTC
Investigating
There are a number of expired & canceled orders displaying on the orderbook. We are working to remove them
Posted Jul 06, 2020 - 20:29 UTC
This incident affected: trade.dydx.exchange.