Orders are slow to process
Incident Report for dYdX V3
Resolved
This incident has been resolved.
Posted Jul 20, 2022 - 21:10 UTC
Investigating
Some orders are slow to process. We are currently investigating the issue.
Posted Jul 20, 2022 - 20:28 UTC
This incident affected: trade.dydx.exchange.