Balances and Positions are slow to update
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 18:59 UTC
Investigating
We are currently investigating this issue.
Posted Aug 07, 2020 - 17:41 UTC
This incident affected: trade.dydx.exchange.