Delays in order processing
Incident Report for dYdX
Resolved
Our matching engine greatly slowed down in its processing of messages (placing/canceling orders). Restarting seems to have fixed the issue. We are still determining the root cause of the original slowdown.

Timeline (times UTC)
11:45 am - slowdown begins
12:16 pm - restart begins
12:18 pm - restart complete
Posted Dec 02, 2021 - 12:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2021 - 12:20 UTC
Investigating
We are currently investigating this issue.
Posted Dec 02, 2021 - 12:16 UTC
This incident affected: trade.dydx.exchange.