Orderbook Not Loading
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Feb 28, 2020 - 22:27 UTC
Investigating
We are currently investigating this issue.
Posted Feb 28, 2020 - 22:15 UTC
This incident affected: trade.dydx.exchange.