UI Slowness in Updating Balances
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Mar 11, 2020 - 18:58 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 11, 2020 - 18:12 UTC
This incident affected: trade.dydx.exchange.