Deposits page is not loading
Incident Report for dYdX
Resolved
This incident has been resolved.
Posted Jul 15, 2022 - 04:31 UTC
Investigating
We are currently investigating this issue.
Posted Jul 15, 2022 - 04:24 UTC
This incident affected: trade.dydx.exchange.